use strict;
my $str = '<table border="0" bgcolor="#FFFFFF"><td bgcolor=...
<table width="780"><td align=...';
my $regex = qr/(<table.*>)(<td.*)/p;
my $subst = '$1<tr>$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";