// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<table.*>)(<td.*)").unwrap();
let string = "<table border=\"0\" bgcolor=\"#FFFFFF\"><td bgcolor=...
<table width=\"780\"><td align=...";
let substitution = "$1<tr>$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}