const regex = /(<table.*>)(<td.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<table.*>)(<td.*)', 'g')
const str = `<table border="0" bgcolor="#FFFFFF"><td bgcolor=...
<table width="780"><td align=...`;
const subst = `$1<tr>$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);