package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\`)
var str = []byte(`if ( antrag . frage ( 'vNamen' ) . istBeantwortet ( ) ) {
antrag.istHauptantrag() ;
} else if (antrag . istAntragGleich ( 'a0001' ) || antrag . istWiederholungsantrag ( ) ) {
antrag.frage('vNamen').feld('name').laenge() > 0;
} else {
true;
}`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}