# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?(myApp)/$1/gm;t' <<< "Line 1: myApp.name;
Line 2: myApp.version
Line 3: myApp.defaults, myApp.numbers;"