// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*?(myApp)").unwrap();
let string = "Line 1: myApp.name;
Line 2: myApp.version
Line 3: myApp.defaults, myApp.numbers;";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}