$re = '/^.*?(myApp)/m';
$str = 'Line 1: myApp.name;
Line 2: myApp.version
Line 3: myApp.defaults, myApp.numbers;';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;