use strict;
my $str = 'Line 1: myApp.name;
Line 2: myApp.version
Line 3: myApp.defaults, myApp.numbers;';
my $regex = qr/^.*?(myApp)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";