re = /^.*?(myApp)/m
str = 'Line 1: myApp.name;
Line 2: myApp.version
Line 3: myApp.defaults, myApp.numbers;'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result