import re
regex = re.compile(r"^.*?(myApp)", flags=re.MULTILINE)
test_str = ("Line 1: myApp.name;\n"
"Line 2: myApp.version\n"
"Line 3: myApp.defaults, myApp.numbers;")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)