using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(myApp)";
string substitution = @"$1";
string input = @"Line 1: myApp.name;
Line 2: myApp.version
Line 3: myApp.defaults, myApp.numbers;";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}