# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?is)(<div[^>]*>(?:(cat)()|(?!<\/?div).|(?1))*+<\/div>)\3//g;t' <<< "<div>
<div> text </div>
<div> <p> cat </p> </div>
<div> <div> text </div> cat </div>
<div> cat <div> text </div> </div>
<div> <div> cat </div> </div>
</div>"