re = /(?is)(<div[^>]*>(?:(cat)()|(?!<\/?div).|(?1))*+<\/div>)\3/
str = '<div>
<div> text </div>
<div> <p> cat </p> </div>
<div> <div> text </div> cat </div>
<div> cat <div> text </div> </div>
<div> <div> cat </div> </div>
</div>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result