using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?is)(<div[^>]*>(?:(cat)()|(?!</?div).|(?1))*+</div>)\3";
string substitution = @"";
string input = @"<div>
<div> text </div>
<div> <p> cat </p> </div>
<div> <div> text </div> cat </div>
<div> cat <div> text </div> </div>
<div> <div> cat </div> </div>
</div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}