use strict;
my $str = '<div>
<div> text </div>
<div> <p> cat </p> </div>
<div> <div> text </div> cat </div>
<div> cat <div> text </div> </div>
<div> <div> cat </div> </div>
</div>';
my $regex = qr~(?is)(<div[^>]*>(?:(cat)()|(?!</?div).|(?1))*+</div>)\3~p;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";