$re = '~(?is)(<div[^>]*>(?:(cat)()|(?!</?div).|(?1))*+</div>)\3~';
$str = '<div>
<div> text </div>
<div> <p> cat </p> </div>
<div> <div> text </div> cat </div>
<div> cat <div> text </div> </div>
<div> <div> cat </div> </div>
</div>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;