import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?is)(<div[^>]*>(?:(cat)()|(?!</?div).|(?1))*+</div>)\\3";
final String string = "<div>\n"
+ " <div> text </div>\n\n"
+ " <div> <p> cat </p> </div>\n\n"
+ " <div> <div> text </div> cat </div>\n\n"
+ " <div> cat <div> text </div> </div>\n\n"
+ " <div> <div> cat </div> </div>\n"
+ "</div>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}