# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?is)(<div[^>]*>(?:(cat)()|(?!</?div).|(?1))*+</div>)\3"
test_str = ("<div>\n"
" <div> text </div>\n\n"
" <div> <p> cat </p> </div>\n\n"
" <div> <div> text </div> cat </div>\n\n"
" <div> cat <div> text </div> </div>\n\n"
" <div> <div> cat </div> </div>\n"
"</div>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.