import Foundation
let pattern = #"(?is)(<div[^>]*>(?:(cat)()|(?!</?div).|(?1))*+</div>)\3"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div>
<div> text </div>
<div> <p> cat </p> </div>
<div> <div> text </div> cat </div>
<div> cat <div> text </div> </div>
<div> <div> cat </div> </div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)