#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?is)(<div[^>]*>(?:(cat)()|(?!</?div).|(?1))*+</div>)\3"
Local $sString = "<div>" & @CRLF & _
" <div> text </div>" & @CRLF & _
"" & @CRLF & _
" <div> <p> cat </p> </div>" & @CRLF & _
"" & @CRLF & _
" <div> <div> text </div> cat </div>" & @CRLF & _
"" & @CRLF & _
" <div> cat <div> text </div> </div>" & @CRLF & _
"" & @CRLF & _
" <div> <div> cat </div> </div>" & @CRLF & _
"</div>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)