const regex = new RegExp('(?is)(<div[^>]*>(?:(cat)()|(?!</?div).|(?1))*+</div>)\\3', 'g')
const str = `<div>
<div> text </div>
<div> <p> cat </p> </div>
<div> <div> text </div> cat </div>
<div> cat <div> text </div> </div>
<div> <div> cat </div> </div>
</div>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);