package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(("[^"]+" *[+] *)+)("[^"]+";)`)
var str = `"039b7" + "7ea14" + "68912" + "909";
"7" + "c" + "7" + "5" + "d" + "1" + "e" + "f" + "1" + "4" + "6" + "8" + "9" + "1" + "2" + "9" + "9" + "4";
"13edf9" + "1a1468" + "913272"; `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}