const regex = /(("[^"]+" *[+] *)+)("[^"]+";)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(("[^"]+" *[+] *)+)("[^"]+";)', 'g')
const str = `"039b7" + "7ea14" + "68912" + "909";
"7" + "c" + "7" + "5" + "d" + "1" + "e" + "f" + "1" + "4" + "6" + "8" + "9" + "1" + "2" + "9" + "9" + "4";
"13edf9" + "1a1468" + "913272"; `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}