import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\"[^\"]+\" *[+] *)+)(\"[^\"]+\";)";
final String string = "\"039b7\" + \"7ea14\" + \"68912\" + \"909\"; \n"
+ "\"7\" + \"c\" + \"7\" + \"5\" + \"d\" + \"1\" + \"e\" + \"f\" + \"1\" + \"4\" + \"6\" + \"8\" + \"9\" + \"1\" + \"2\" + \"9\" + \"9\" + \"4\"; \n"
+ "\"13edf9\" + \"1a1468\" + \"913272\"; ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}