re = /(("[^"]+" *[+] *)+)("[^"]+";)/
str = '"039b7" + "7ea14" + "68912" + "909";
"7" + "c" + "7" + "5" + "d" + "1" + "e" + "f" + "1" + "4" + "6" + "8" + "9" + "1" + "2" + "9" + "9" + "4";
"13edf9" + "1a1468" + "913272"; '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end