import re
regex = re.compile(r"((\"[^\"]+\" *[+] *)+)(\"[^\"]+\";)")
test_str = ("\"039b7\" + \"7ea14\" + \"68912\" + \"909\"; \n"
"\"7\" + \"c\" + \"7\" + \"5\" + \"d\" + \"1\" + \"e\" + \"f\" + \"1\" + \"4\" + \"6\" + \"8\" + \"9\" + \"1\" + \"2\" + \"9\" + \"9\" + \"4\"; \n"
"\"13edf9\" + \"1a1468\" + \"913272\"; ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")