// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(("[^"]+" *[+] *)+)("[^"]+";)"#).unwrap();
let string = "\"039b7\" + \"7ea14\" + \"68912\" + \"909\";
\"7\" + \"c\" + \"7\" + \"5\" + \"d\" + \"1\" + \"e\" + \"f\" + \"1\" + \"4\" + \"6\" + \"8\" + \"9\" + \"1\" + \"2\" + \"9\" + \"9\" + \"4\";
\"13edf9\" + \"1a1468\" + \"913272\"; ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}