# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((<CnlNum>)|(Val\s?\())([5-9])(\d{2})((?(2)<\/CnlNum>|\),\s?))/($1)1$4$5$6/gm;t' <<< " <CnlNum>548</CnlNum>
GetBit(Val(548), 3)
<CnlNum>548),"