package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((<CnlNum>)|(Val\s?\())([5-9])(\d{2})((?(2)</CnlNum>|\),\s?))`)
var str = ` <CnlNum>548</CnlNum>
GetBit(Val(548), 3)
<CnlNum>548),`
var substitution = "($1)1$4$5$6"
fmt.Println(re.ReplaceAllString(str, substitution))
}