import Foundation
let pattern = #"((<CnlNum>)|(Val\s?\())([5-9])(\d{2})((?(2)</CnlNum>|\),\s?))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<CnlNum>548</CnlNum>
GetBit(Val(548), 3)
<CnlNum>548),
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"($1)1$4$5$6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)