#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((<CnlNum>)|(Val\s?\())([5-9])(\d{2})((?(2)</CnlNum>|\),\s?))"
Local $sString = " <CnlNum>548</CnlNum>" & @CRLF & _
" GetBit(Val(548), 3)" & @CRLF & _
"<CnlNum>548),"
Local $sSubst = "($1)1$4$5$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)