import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((<CnlNum>)|(Val\\s?\\())([5-9])(\\d{2})((?(2)</CnlNum>|\\),\\s?))";
final String string = " <CnlNum>548</CnlNum>\n"
+ " GetBit(Val(548), 3)\n"
+ "<CnlNum>548),";
final String subst = "($1)1$4$5$6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}