use strict;
my $str = ' <CnlNum>548</CnlNum>
GetBit(Val(548), 3)
<CnlNum>548),';
my $regex = qr~((<CnlNum>)|(Val\s?\())([5-9])(\d{2})((?(2)</CnlNum>|\),\s?))~mp;
my $subst = '($1)1$4$5$6';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";