using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((<CnlNum>)|(Val\s?\())([5-9])(\d{2})((?(2)</CnlNum>|\),\s?))";
string substitution = @"($1)1$4$5$6";
string input = @" <CnlNum>548</CnlNum>
GetBit(Val(548), 3)
<CnlNum>548),";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}