$re = '~((<CnlNum>)|(Val\s?\())([5-9])(\d{2})((?(2)</CnlNum>|\),\s?))~m';
$str = ' <CnlNum>548</CnlNum>
GetBit(Val(548), 3)
<CnlNum>548),';
$subst = "($1)1$4$5$6";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;