const regex = new RegExp('((<CnlNum>)|(Val\\s?\\())([5-9])(\\d{2})((?(2)</CnlNum>|\\),\\s?))', 'gm')
const str = ` <CnlNum>548</CnlNum>
GetBit(Val(548), 3)
<CnlNum>548),`;
const subst = `($1)1$4$5$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);