// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((<CnlNum>)|(Val\s?\())([5-9])(\d{2})((?(2)</CnlNum>|\),\s?))").unwrap();
let string = " <CnlNum>548</CnlNum>
GetBit(Val(548), 3)
<CnlNum>548),";
let substitution = "($1)1$4$5$6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}