#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^|[^_])\bproducts\b([^_]|$)"
Local $sString = "{% macro products_list(products) %}" & @CRLF & _
"{% for product in products %}" & @CRLF & _
"productsList" & @CRLF & _
"{% endfor %}" & @CRLF & _
"{% endmacro %}"
Local $sSubst = "$1.$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)