$re = '/(^|[^_])\bproducts\b([^_]|$)/';
$str = '{% macro products_list(products) %}
{% for product in products %}
productsList
{% endfor %}
{% endmacro %}';
$subst = "$1.$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;