const regex = /(^|[^_])\bproducts\b([^_]|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^_])\\bproducts\\b([^_]|$)', 'g')
const str = `{% macro products_list(products) %}
{% for product in products %}
productsList
{% endfor %}
{% endmacro %}`;
const subst = `$1.$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);