// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^|[^_])\bproducts\b([^_]|$)").unwrap();
let string = "{% macro products_list(products) %}
{% for product in products %}
productsList
{% endfor %}
{% endmacro %}";
let substitution = "$1.$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}