use strict;
my $str = '{% macro products_list(products) %}
{% for product in products %}
productsList
{% endfor %}
{% endmacro %}';
my $regex = qr/(^|[^_])\bproducts\b([^_]|$)/p;
my $subst = '$1.$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";