re = /(^|[^_])\bproducts\b([^_]|$)/
str = '{% macro products_list(products) %}
{% for product in products %}
productsList
{% endfor %}
{% endmacro %}'
subst = '$1.$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result