using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^_])\bproducts\b([^_]|$)";
string substitution = @"$1.$2";
string input = @"{% macro products_list(products) %}
{% for product in products %}
productsList
{% endfor %}
{% endmacro %}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}