# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^[^\(\)]*?\()?(?:(.*?\)),|(.*?)\)$)//g;t' <<< "func1(func2(arg1, arg2),func3(func4(arg3)),arg4)"