$re = '/(?:^[^\(\)]*?\()?(?:(.*?\)),|(.*?)\)$)/';
$str = 'func1(func2(arg1, arg2),func3(func4(arg3)),arg4)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;