#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:^[^\(\)]*?\()?(?:(.*?\)),|(.*?)\)$)"
Local $sString = "func1(func2(arg1, arg2),func3(func4(arg3)),arg4)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)