import Foundation
let pattern = #"(?:^[^\(\)]*?\()?(?:(.*?\)),|(.*?)\)$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"func1(func2(arg1, arg2),func3(func4(arg3)),arg4)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)