use strict;
my $str = 'func1(func2(arg1, arg2),func3(func4(arg3)),arg4)';
my $regex = qr/(?:^[^\(\)]*?\()?(?:(.*?\)),|(.*?)\)$)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";