// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:^[^\(\)]*?\()?(?:(.*?\)),|(.*?)\)$)").unwrap();
let string = "func1(func2(arg1, arg2),func3(func4(arg3)),arg4)";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}